full screen mode no longer works

You are viewing a static copy of the old 2DBoy forum, which closed in 2010. It is preserved here for historical interest, but it is not possible to reply to topics. For more recent discussion about World of Goo, visit our new forum.
full screen mode no longer worksw0lfie12/28/2008 - 23:10

I hit alt+enter to get into windowed mode. Now whenever I try to run it in full screen mode, it is just a black screen. The old mouse arrow-style cursor shows for a few seconds, so I know the screen is in the right resolution, etc. There are music and sfx when I move the mouse, so I'm sure the program's running. Also, when I alt+enter back into windowed mode, right before the window pops up, the screen flashes what is should have had on it the whole time. Is this a direct X problem? I have a HP Pavilion zd8000 with a Radeon x600 card (which I must admit has been a little buggy ever since the forced me to upgrade my drivers). Do I need to disable Dirct3D and force it to use OpenGL? When I played portal I had to force it to use a lower version of some thingamagiggy, so maybe this is a similar problem.

Re: full screen mode no longer worksastrosoup12/31/2008 - 03:46

Same thing happened to me. I was one ball away from OCD and I pulled down the wrong one, and I couldn't hit "escape" to retry and in a moment of intense frustration while waiting through the level completion paperwork (without any ability to interrupt or retry) I facerolled my keyboard and went into windowed mode. After I alt-entered to restore, it just gave me a black screen with my goo cursor present.

Re: full screen mode no longer worksw0lfie01/01/2009 - 09:00

hmmm... no goo ball cursor for me, so probably not the same problem. I'm pretty sure it's an ATI problem, but I don't know how to fix it. I found the config file and made it fill nearly my whole screen, so close enough.