direct 3d problem

You are viewing a static copy of the old 2DBoy forum, which closed in 2010. It is preserved here for historical interest, but it is not possible to reply to topics. For more recent discussion about World of Goo, visit our new forum.
direct 3d problemdirect3dproblem01/28/2009 - 23:51

Two out of the 3 computers I have tried to get WOG running on say "Failed to find compatible Direct3d device"...won't start...installed the newest version of DirectX from Microsoft...still no good...I have read through some of the other posts but can't seem to make sense of it all...I am thinking graphics driver???  Any ideas?  Thanks, David

Re: direct 3d problemxanax01/29/2009 - 00:18

Are you able to play other games with these computers ?

Otherwise you can try to launch "C:\Windows\System32\dxdiag.exe" and see if you have problems with directx/direct3d.

Also, check if your graphics cards (nvidia, ATI) are well recognized by Windows in the "Control Panel" > "System Properties" > "Device Manager". If you notice a yellow roadsign /!\ next to your graphics card, then there's probably a problem with drivers.

Re: direct 3d problemdirect3dproblem01/29/2009 - 09:29

Tried yellow signs  (Ratheon 1400 video chip)...went into C all the way into the directx folder...there is NO .exe there....just a bunch of other files....could that be part of the problem?

Re: direct 3d problemxanax01/29/2009 - 12:26

There ARE exe files there. It's just that Windows hides file extensions by default.

To enable the viewing of Hidden files follow these steps:

  1. Click on the Control Panel menu option.
  2. When the control panel opens, be sure to be in Classic View.
        - Double-click on the Folder Options icon.
        - Click on the View tab.

  3. Under the Hidden files and folders section select the radio button labeled Show hidden files and folders.
  4. Remove the checkmark from the checkbox labeled Hide extensions for known file types.
  5. Press the Apply button and then the OK button and shutdown My Computer.
  6. Now Windows Vista is configured to show all hidden files.

Re: direct 3d problemdirect3dproblem01/29/2009 - 21:43

OK..I got in that .exe and ran it....I think this is barking up the right tree...because when I tried to test the Direct 3D device it would not test...said it had no functionality.  On the computer that runs WOG, I could test that....

So, any ideas how to get that going??  I did install the newest version of directx straight from Microsoft, so I am not sure what else there is to do??

Thanks,  David