Corporation connection problems.

You are viewing a static copy of the old 2DBoy forum, which closed in 2010. It is preserved here for historical interest, but it is not possible to reply to topics. For more recent discussion about World of Goo, visit our new forum.
Corporation connection problems.Rich12302/14/2009 - 14:11

Recently bought the game and played through the first 2 chapters, then went into Corporation and hit the connect button on the billboard and it connected.

Next day (today), I go onto corporation again and this time there are no clouds, not even the ranks in the top right corner where they should be. My internet connection is fine as I'm using it now with no problems.

Any help will be greatly appreciated,

Re: Corporation connection problems.TheHermit02/16/2009 - 13:43

Same problem here.
Worked fine last night when using the demo. Bought the full game this afternoon and after 3 hours all I  get is the "tallest in the world" in the top right corner but still no clouds, yet no internet problems with any other program...

Last modified Mon, 02/16/2009 - 14:35 by TheHermit
Re: Corporation connection problems.earthpigg02/16/2009 - 15:54

for me, they often dont show up until i've been building for a few minutes.

perhaps the game has more people playing than 2dboy expected and their servers are being overworked?

no DRM means they have to purchase/maintain servers for all the people pirating the game that are connecting to the servers.

the No DRM that 2dboy is implimenting is actually no DRM... remember, you dont even have to register your e-mail address to connect to the server and play.

Re: Corporation connection problems.TheHermit02/16/2009 - 17:55

Well after clearing pers2.dat (in case that was the problem) then restarting with a fresh profile and playing for two hours+ straight... Still no clouds. Just "tallest in the world" which changed a few times. :(

Re: Corporation connection problems.TheHermit02/17/2009 - 16:30

Looks like it was server issues yesterday as today both Linux & Windows versions eventually display correctly BUT the height of my tower is displayed differently when using the EXACT SAME PROFILE (0.1 taller in Linux...) and the "tallest in the world" is seems to be different too... although that could be because of the slight gap between disconnecting from one version and connecting on the other...

Re: Corporation connection problems.Soultaker02/17/2009 - 16:54

For what it's worth, I think these problems are with 2D Boy's server, and not with your installations, so reinstalling the game or starting a new profile probably won't help.

The leaderboards are undergoing some upgrades right now; hopefully afterward the clouds will be fixed too.

Last modified Tue, 02/17/2009 - 16:55 by Soultaker
Re: Corporation connection problems.TheHermit02/18/2009 - 10:48

Fair enough. Thought I'd check all options at this end seeing as nothing was being mentioned officially about server trouble. Thanks anyway! :D

Re: Corporation connection problems.SnakeChomp03/09/2009 - 21:55

I'm seeing similar symptoms as well. The other night I was able to see clouds properly, but for the last few days I haven't been able to get them to appear. It would be nice to see some sort of official announcement if there really is a server problem as it seems to have been happening for quite some time now.

Re: Corporation connection problems.TheHermit03/10/2009 - 11:06

It's been VERY busy this weekend with new people joining us after the Steam special offer, so I'd guess the server is unable to cope at the moment.