Mouse cursor in Linux ver.

You are viewing a static copy of the old 2DBoy forum, which closed in 2010. It is preserved here for historical interest, but it is not possible to reply to topics. For more recent discussion about World of Goo, visit our new forum.
Mouse cursor in Linux ver.calebegg02/16/2009 - 10:19

Whenever I run WoG, it opens up the title screen (or what I assume is the title screen) with the music, but neither my mouse nor my keyboard have any effect at all. The only way to make the program exit (as far as I can tell) is to force an X restart (Ctrl+Alt+Bksp).

I found out at some point that I can take it out of full screen with Alt+Enter. When I do this the mouse cursor is visible (it's not visible in full screen) but cannot leave the WoG window, even when I exit WoG with Alt+F4, and cannot click. After I exit, the window is gone but the mouse still can't leave that rectangle of the screen and still doesn't work.

I'm running Ubuntu Intrepid, latest version with all updates, x64.

Any suggestions?

Re: Mouse cursor in Linux ver.earthpigg02/16/2009 - 16:00

tried turning compiz off?

alt+f2 -> metacity --replace

(compiz --replace to turn it back on without losing any of your settings)

or you can do system->preferences->appearance and turn visual effects off there... but you may lose your compiz settings.

if that does the trick, i suggest trying with compiz turned on but any/all mouse effects turned off... i know, for example, that desktop zoom is pretty buggy.

Re: Mouse cursor in Linux ver.calebegg02/16/2009 - 18:32

Nope, no luck with that. I don't have any of the visual effects on -- I'm using xinerama and therefore not xrandr and therefore no visual effects (anyway, I assume that's why). Could the lack of xrandr be part of the issue?

If posting my xorg.conf would help, I can do that. I have made some changes to it.

Re: Mouse cursor in Linux ver.Soultaker02/16/2009 - 19:26

Not that this is a full solution, but could you try starting the game in windowed mode to see if that does work? (You can do this by editing /opt/WorldOfGoo/properties/config.txt and setting "fullscreen" to "false").

Re: Mouse cursor in Linux ver.calebegg02/16/2009 - 19:30

Yes, actually, that worked. I had decided not to try since I figured starting it in fullscreen and then pressing alt+enter would have the same result as starting it in windowed mode. This is fine for me; I wanted it windowed anyway. But I'll be checking the thread if anyone would like any other diagnostic information (to solve the base problem for other users).


Re: Mouse cursor in Linux ver.Soultaker02/16/2009 - 19:35

Good thing that worked, because I have no idea what the real issue is, unfortunately.

What kind of hardware and drivers are you using? (I wouldn't be surprised if this is another weird problem related to Intel's graphic drivers.)

Re: Mouse cursor in Linux ver.Soultaker02/18/2009 - 18:05

For other users who experience this problem, there are two things that seem to work around it, both involve editing /opt/WorldOfGoo/properties/config.txt:
1. set "fullscreen" to "false" and play in windowed mode, or:
2. set the game resolution ("screen_width" and "screen_height") to your desktop resolution.