config changed => game doesn't start anymore :-(

You are viewing a static copy of the old 2DBoy forum, which closed in 2010. It is preserved here for historical interest, but it is not possible to reply to topics. For more recent discussion about World of Goo, visit our new forum.
config changed => game doesn't start anymore :-(dentaku02/22/2009 - 11:40

Just tested the entry

  <param name="manymouse" value="true" />

but the mouse was away. Than I changed it back (?) to

  <param name="manymouse" value="false" />

but now the game doesn't start anymore. In a console, it just says "Aborted" ... I deinstalled the package and reinstalled again, but it doesn't help: it doesn't start anymore - it alweays says just "Aborted" in a a shell. .... please help!  :'(

Last modified Sun, 02/22/2009 - 11:49 by dentaku
Re: config changed => game doesn't start anymore :-(Soultaker02/22/2009 - 11:51

The Sign Painter warned you not to change anything there!

Seriously though. Could you post the contents of $HOME/.WorldOfGoo/WorldOfGoo.log?

Did you copy the config to $HOME/.WorldOfGoo/ before editing? If so, you may have to remove it there to get the default behaviour back.

Re: config changed => game doesn't start anymore :-(dentaku02/22/2009 - 12:03

Yes, I read that. But I changed the resolution and this worked, so I thought changing a simple "false" to true" can be savely undone ...  :(

I ensured that /op/WorldOfGee/ was removed and also deleted ~/.WorldOfGoo but it didn't help. Here's the log after fresh reinstall:

[t=0.00] Failed to read persistent data from "/home/dentaku/.WorldOfGoo/pers2.dat"!
[t=0.00] Locale de_DE.UTF-8@euro matched to language de.
[t=0.00] Primary language: de
[t=0.00] Created 800x600 (32 bpp) graphics surface.
[t=0.00] Created virtual viewport of size 800(+0)x600(+0)
[t=0.00] Using audio driver: alsa

Re: config changed => game doesn't start anymore :-(Soultaker02/22/2009 - 12:09

Maybe something silly like no more free audio channels? Did you try rebooting in between crashes?

Re: config changed => game doesn't start anymore :-(dentaku02/22/2009 - 12:19

Yep, I rebooted. And I found the problem: pulseaudio!!! When I start WorldOfGoo, the message "Aborted" is displayed in the shell. But after I killed the process "pulseaudio", it works again *phewww!*  :)  I thought about pulseaudio because I had some other problems with games in the past that were solved after killing pulseaudio!

Re: config changed => game doesn't start anymore :-(Soultaker02/22/2009 - 14:08

Do you happen to use a 64-bit distribution?

If so, the problem is probably that you don't have 32-bit Pulse Audio libraries installed. Then, the game falls back to using ALSA, which fails if Pulse Audio has already started and claimed the audio device. A better solution may be to use Pulse Audio in the game too, but then you also get the lag that Pulse Audio causes.

Re: config changed => game doesn't start anymore :-(dentaku02/22/2009 - 17:35

Yes, I run 64 Bit Linux and installed World of Goo with --force-architecture. I read of many people having problems with PulseAudio but never heard about some missing 32 Bit Libs. Is there such a package to be installed in /lib32 ?

Just found the thread "PROPERLY install World of Goo on 64bit Debian/Ubuntu Linux" (,1464.msg9805.html") but it doesn't address the pulseaudio problem.

Last modified Sun, 02/22/2009 - 17:58 by dentaku