Goo not loading

You are viewing a static copy of the old 2DBoy forum, which closed in 2010. It is preserved here for historical interest, but it is not possible to reply to topics. For more recent discussion about World of Goo, visit our new forum.
Goo not loadingmarkdca12/05/2008 - 02:45

Hello. I tried to email Steam support last week, but there has been no response. (great support...)

When I try to launch World of Goo from steam, nothing happens. It just displays the loading cursor for a couple seconds and stops. I tried launching WorldOfGoo.exe directly from the installation folder with admin privileges. Then a message pops up saying:

Exception: Access Violation (code 0xc0000005) at address 0047F9DF in thread 320
Module: WorldOfGoo.exe
Logical Address: 0001:0007E9DF

0017FF88 0047F9DF 0001:0007E9DF WorldOfGoo.exe
Params: 7EFDE000 0017FFD4 77A4CFED 7EFDE000

StackWalk failed (error 299)

EAX:00000000 EBX:00000000 ECX:02C90AD0 EDX:00250E58 ESI:01116018 EDI:002427F0
EIP:0047F9DF ESP:0017FE60 EBP:0017FF88
CS:0023 SS:002B DS:002B ES:002B FS:0053 GS:002B

Windows Ver: NT 6.0 Service Pack 1 Build 6001

I do not have Threatfire installed. Any ideas? Thank you.