New levels from command line doesn't work.

You are viewing a static copy of the old 2DBoy forum, which closed in 2010. It is preserved here for historical interest, but it is not possible to reply to topics. For more recent discussion about World of Goo, visit our new forum.
New levels from command line doesn't work.davidc11/07/2008 - 08:26

Take a level, any level. I chose EconomicDivide.

Copy it to MyLevel. Replace all _ECONOMICDIVIDE_ variables with _MYLEVEL_ (except text keys, unless you're also editing text.xml).

Launch "WorldOfGoo.exe MyLevel".

It goes through the loading sequence fine, and displays the intro title page (testing 1 2 3) fine, but once it tries to display the level it crashes.

Rename MyLevel back to EconomicDivide, and run "WorldOfGoo.exe EconomicDivide" and it runs fine, even though the references inside the level are all _MYLEVEL_. This indicates it's not the actual files that are bad, it's something about the directory name.

I thought it might be something to do with it not having an island.xml entry to lookup OCD requirements, but I tried adding one and it didn't help. I can't see any other references to EconomicDivide in the XML files, so I tried a simple "strings WorldOfGoo.exe  | grep Econom" to see if it was hardwired in the code, but I didn't find anything there either.

Has anyone successfully launched a *new* level?

Here's the error when launching a custom level (version 1.20):

Exception: Access Violation (code 0xc0000005) at address 0043FC5C in thread 9C4
Module: WorldOfGoo.exe
Logical Address: 0001:0003EC5C

0012F81C 0043FC5C 0001:0003EC5C WorldOfGoo.exe
Params: 01E7D308 01E20ED8 058EBA98 00000000

StackWalk failed (error 299)

EAX:00000000 EBX:059182A0 ECX:00000000 EDX:005E19C4 ESI:01E7D308 EDI:FFFFFFFF
EIP:0043FC5C ESP:0012F780  EBP:0012F81C
CS:001B SS:0023 DS:0023 ES:0023 FS:003B GS:0000

Windows Ver: NT 6.0 Service Pack 1 Build 6001
DDraw Ver: 6.0.6000.16386
DSound Ver: 6.0.6000.16386

Product: Product
Time Loaded: 00:00:18
Fullscreen: No
Primary ThreadId: 9C4


Last modified Fri, 11/07/2008 - 08:29 by davidc
Re: New levels from command line doesn't work.zark9211/07/2008 - 09:40

Yes, it works great for me.

Did you remember to rename the level name reference in the scene file ?

See Soultaker procedure (just skip the island stuff and follow the level name stuff):

Re: New levels from command line doesn't work.davidc11/07/2008 - 10:21

Yeah. I think it's because I was manually editing a version of text.xml from an old version (had no internet). I'm auto-merging it with GooTool now and it's working fine.

Still, would be nice to get some logging so we can find out the reason for crashes (missing resource or whatever).