Fatal Error Alert!

You are viewing a static copy of the old 2DBoy forum, which closed in 2010. It is preserved here for historical interest, but it is not possible to reply to topics. For more recent discussion about World of Goo, visit our new forum.
Fatal Error Alert!GooGun11/22/2008 - 20:54

Alright, so I finished making my level. However, whenever I try to play my level (it's been inserted as an addin with Goo Tool), it gives me this:

"Exception: Access Violation (code 0xc0000005) at address 0055BD31 in thread 1374
Module: WorldOfGoo.exe
Logical Address: 0001:0015AD31

0012F8B4 0055BD31 0001:0015AD31 WorldOfGoo.exe
Params: 0012F8EC 00610ECC 0012FA7C 07E34440

StackWalk failed (error 299)

EAX:00000000 EBX:0012F8EC ECX:00000000 EDX:CD621C10 ESI:003ED200 EDI:0DE2D4F0
EIP:0055BD31 ESP:0012F80C  EBP:0012F8B4
CS:001B SS:0023 DS:0023 ES:0023 FS:003B GS:0000

Windows Ver: NT 6.0 Service Pack 1 Build 6001
DDraw Ver: 6.0.6000.16386
DSound Ver: 6.0.6000.16386

Product: Product
Time Loaded: 00:00:21
Fullscreen: No
Primary ThreadId: 1374"

Anything I'm missing? This really doesn't make sense. Please hurry, I wish to play my level...

Re: Fatal Error Alert!zark9211/23/2008 - 15:05

This is a fairly common error when you try to play the level with invalid data. WOG does not do any error checking and just assumes the level data are valid.

Try the following:
- open the level if WOG Editor and check if there is any warnings (there still a lot that is not validated, but if you hacked the XML by hand, it may find an error or two).
- if this give no result, try removing part of the level until you can figure out which part is causing the issue.

Re: Fatal Error Alert!GooGun11/24/2008 - 17:49

Ok, so I tried opening the level with WOGEditor, but it won't open. What does that mean?

Re: Fatal Error Alert!zark9211/27/2008 - 14:02

Do you mean that the level does show in the list of editable level ? In any case, check the console window for any errors.

Re: Fatal Error Alert!davidc12/10/2008 - 19:00

Unfortunately as zark92 mentions, WOG doesn't give any useful diagnostics on level load crashes. The solution is to revert to your last known good copy and incrementally apply the changes until you find which one broke it. If you don't have a known good copy, try removing elements one by one (making sure you don't have anything referencing anything else by id).


Re: Fatal Error Alert!GooGun12/14/2008 - 13:37

Alright, so I got this message while trying to play another level I made, and The Other Side of the Dispenser. I start to think that the demo version is the culprit. Could it be? Or is it a strange coincidence?

Re: Fatal Error Alert!GooGun12/24/2008 - 11:15

ALright, so I have the full version. I tried playing my newest level with GooTool, but to no avail. Same crash, once again. However, other levels work, but not this one.

Does anyone know what that StackWalk Failed (299) is about? That would be of tremendous help. Ah well, I'll stick to playing in the Editor for now.

Re: Fatal Error Alert!davidc12/24/2008 - 11:19

There's something wrong with your level. I know that's not very helpful but the error is always very vague like this. Make a backup of your level, then try removing things one by one until the level works.

Usually when I get this message, I'm referencing an invalid ball type or missing image etc. But there can be many causes.