Can't merge level addins with GooTool on Linux

6 replies [Last post]
Joined: 12/23/2008

Since I upgraded to 1.0.3, GooTool isn't able to merge in any levels anymore. For example, if I try to install JingleBalls, which worked fine before, I get a cryptic error message:

ERROR:  'The value of attribute "fi" associated with an element type "null" must not contain the '<' character.'
ERROR:  ' The value of attribute "fi" associated with an element type "null" must not contain the '<' character.'

Some non-level mods do work; for example Pavke's Towersome mod still works.

I have already removed my "custom" WorldOfGoo directiory, as well as .gootool (which just stores addons at the moment; no settings as far as I can tell) but no avail. Does anyone know what's wrong, or how to debug this further?

Joined: 03/31/2009

Hi Soultaker

Yeah, GooTool 1.0.3 has some bugs, I'm having some trouble with it too, well, not the kind you are having. Sorry, can't help you with yours, I probably know less then 1% about Linux then you do.

But, can you test something for me? Run World of Goo with GooTool(empty) and go to Corporation and wait a few moments.. does it start lagging? Quit and try to start WoG again by GooTool? Can you?

Davidc mysteriously disappeared so we have to wait till he comes back...

My Gooish profile | Videos on YouTube | My WOG Mods

Joined: 12/23/2008

WoGC seems to work fine for me. But that's to be expected, because if I don't merge in any addins, then GooTool doesn't really modify the game files in any significant way.

I guess I'll wait for davidc to make a good suggestion, or maybe I'll check out the source code (which is now available) myself, if I can spare the time...

Joined: 11/04/2008

Soultaker - is there a (probably cryptic) traceback in the logs to accompany this error so I can see where it's occurring?

Joined: 12/23/2008

A log file is here: (This was created with a freshly-downloaded copy of Jingle Balls.) I can't really make anything out of it other than "XSL transformation fails somewhere, somehow".

By the way, is there a reason you obfuscate the class names in the binary distribution, even though GooTool itself is now open source?

Joined: 11/04/2008

It looks like you are using an old version of Jingle Balls - can you try the latest? It's possible the old version didn't have the right charset on that XSL file; the error is coming from one of the Russian translations.

I suppose there's no reason to obfuscate the classes any more. I originally did it because the early code was quite embarrassing.


Joined: 12/23/2008

Late reaction, I know, but I'm sure I'm using the latest version of both gootool and Jingle Balls. Just to be sure, I redownloaded GooTool from and Jingle Balls from

I removed directories $HOME/.gootool, my customized World of Goo directory, and $HOME/.java/.userPrefs/com/goofans entirely, which seems to get rid of all settings and add-ins. Extracting a fresh copy of GooTool, installing and enabling the add-in, and then saving, yields the same error.

So I'm pretty sure it's something in the latest version of GooTool, especially since I haven't had problems before. I'll try to investigate the issue in detail when I have some free time!