More problems with GooTool (sorry)

3 replies [Last post]
Joined: 06/19/2009

Not to really "pile on"... but...
<dependencies> doesn't seem to work either.

Just tried inwog's new level which depends on his MetalSandbox addin.
I had an earlier version than was required, and it wasn't enabled...
But GooTool didn't flag an issue and saved without complaint.. but the level couldn't work (missing balls)
The <dependencies> and <depends> in his addin.xml look fine.

I tried it again after uninstalling the Sandbox addin, and GooTool still didn't complain... Puzzled
Is it just me?

If I try to install an addin from the addins folder... (probably shouldn't do that but)... GooTool asks you the "Install this addin questions" then comes up with an error

GooTool wrote:
Couldn't install the addin: {Full Path and Filename of the .goomod} (The system cannot find the file specified)

When you go and look, the goomod file is gone.. deleted I assume!
Might be nice if it didn't do that! Wink

thB's picture
ContributorAddin AuthorKleptomaniacToo Much Free TimeSerious OCD
Joined: 04/17/2009

Regarding dependencies: davidc stated that the dependency system is not working. So, it's not really an issue, but more of a "known feature yet to be fully implemented". Smile
For the time being, it's nice to define dependencies, but they are not used by GooTool (except for displaying them).
I've also been waiting for this feature to be implemented ever since, but I suppose it'd require quite some work.

my gooey profile | my video channel | author of Hazardous Environment

Joined: 06/19/2009

thB wrote:
Regarding dependencies: davidc stated that the dependency system is not working.

Really? Not anywhere I've looked... Puzzled

It might be worth adding a note onto the Manifest File page where those tags are described... eh..?

I don't think it's a huge problem that it doesn't work... the bigger problem is..
People think it does, and it doesn't.

If it was made VERY clear that it didn't work, folk would find other ways around it, like adding links into the addin descriptions, or just including the necessary files in the goomod in the first place.

Joined: 11/04/2008

Yeah this is a known issue. It's supposed to work but it's only half-heartedly coded. Particularly, I think it may only check when you use "Install new addin" button, but not when you double-click a goomod file Smile

I'll try and get to this soon.

Regarding the other issue, you're not supposed to touch your custom WoG directory. "Will not fix", because there's going to be a large refactoring of how the custom WoG is built in the future in order to support other output targets like iPad-via-scp - this will likely involve moving available addins to the user's profile directory.