Gootool and java 8 on linux

1 reply [Last post]
Joined: 05/27/2015

When I try to run gootool on debian (with java 8 installed) I get message in console:

"GooTool requires Java 1.5 or 1.6. You have Java 1.8.

Here: it says that I need "Java 1.5.0 or greater". So according to gootool version 1.8 < version 1.5.
Do I REALLY need to install java 6?

Note: I installed it from .deb package.

Apparently it works with java 8 (at least it starts). When I cd to /usr/share/gootool and run it manually:
java -cp gootool.jar:jsch-0.1.42.jar:lcrypto-jdk15141.jar:AppleJavaExtensions.jar:uiruntime.jar com.goofans.gootool.GooTool
It works.
But why authors of gootool couldn't predict that newer versions of java will be released?

It doesn't seem to work. At first it couldn't detect my steam WorldOfGoo installation (I had to copy WorldOfGoo executable and rename the copy too WorldOfGoo.bin).
The it started successfully.
When I tried to run it with gootool (after changing language) it created it;s own copy of WoG and... did nothing.
So I tried to run it manually:
./WorldOfGoo.bin: error while loading shared libraries: cannot open shared object file: No such file or directory
So I installed libsdl1.2debian:i386.
But after that it complains that it can't find
Is it possible to use gootool with steam version of WorldOfGoo on linux?
Or is it possible to use gootool with steam version at all?
If so, how to do that?

I finally got it working.
For those who have the same problem in the future (I couldn't find anything on google):
After gootool copied WorldOfGoo to other folder I had to do this:
ln -s "$HOME/.steam/steam/steamapps/common/World of Goo/libs32" "/location/of/modded/worldofgoo/"
Optionally repeat the above for icons and docs directories.
cd "location/of/modded/worldofgoo"
echo 22000 > steam_appid.txt
and if WorldOfGoo.bin is not executable:
chmod +x WorldOfGoo.bin

I don't know how to do it on windows

The fix for gootool not starting turns out to be simple.
The issue is in gootool sh script.
I changed

if [ "${JAVA_VERSION}" != "1.5." -a "${JAVA_VERSION}" != "1.6." ]; then


if [ "${JAVA_VERSION}" = "1.1." -o "${JAVA_VERSION}" = "1.2." -o "${JAVA_VERSION}" = "1.3." -o "${JAVA_VERSION}" = "1.4." ]; then

and it starts normally with 'gootool' command.

Joined: 09/01/2009

Yeah, that gootool shell script testing for 1.5 or 1.6 only is quite annoying. Glad you got it sorted! For some reason, I thought I had that solution in a stickied post, but I guess not. So you can be the first!