GooTool will not run on a Mac using Java 7

3 replies [Last post]
Joined: 03/01/2014

I'm using Mac OS 10.9 and have Java 7 installed.

When I run, I get a dialog that says "To open, you need a Java SE 6 runtime. Would you like to install one now?" and has two buttons "Not Now" and "Install". If I click "Not Now", it simply quits. No GooTool. As for clicking "Install", I'm sorry, but I'm not willing to remove 7 and somehow force 6 onto Mavericks just to see if GooTool will then work.

At a command line:
[user@machine:~]$ java -version
java version "1.7.0_51"
Java(TM) SE Runtime Environment (build 1.7.0_51-b13)
Java HotSpot(TM) 64-Bit Server VM (build 24.51-b03, mixed mode)

All I set out to do was get my progress in WOG transferred from a Win machine to a Mac!

Joined: 09/01/2009

As far as I know (And according to ), you ought to be able to install both Java 6 and Java 7 on the same machine without doing anything special. may help a bit. Some of the discussion on may help as well, even though it's targeted more at installing the Java 7 JDK than the Java 6 JRE.

If none of this works, I can file a bug report and ask davidc to update the Java version that OSX GooTool uses. I suspect that may take him a while, however.

Joined: 11/04/2008

Well, that's interesting (and frustrating); the whole reason I had to keep GooTool backwards-compatible to Java 1.5 was to support Macs since Apple wouldn't (at the time) update.

You can probably fix this by replacing the JavaApplicationStub inside the app with a more recent one from Apple, damned if I know where to find it though. If you do find it, let me know and I'll release a new version.


Joined: 03/17/2009

How did you get Java 7 on your machine?

I'm not familiar with Osx 10.9. I'm using 10.7.

Attempting to get the J7 runtime on was a failure. Yes, I could adjust PATH for the command line, but anything that involved launch services (double clicking) used lookups that I could not control, and would not find the J7 runtime in the internet plugins.

I had to install the full J7 SDK; then, it just worked.