Windows type?

2 replies [Last post]
Joined: 05/11/2011

Just wondering what version of windows is needed to run woogle, wooble & the movie maker.

I give critique to recent levels.

Also...
You've waited, and I finally have delivered!
World of Goo 1/2 Chapter 3 is finally here!

Joined: 04/29/2011

It should work on WinXp/Vista/7/8/8.1/10

Joined: 12/04/2014