Error when trying to save and play first level

7 replies [Last post]
Joined: 04/24/2010

Greetings all. Trying to save and play the first level I created. Followed the video tutorial and I'm getting the error below. Any ideas?

Exception: Access Violation (code 0xc0000005) at address 004B3710 in thread 140
Module: WorldOfGoo.exe
Logical Address: 0001:000B2710

05C1F8C0 004B3710 0001:000B2710 WorldOfGoo.exe
Params: 00000000 0000001C 00000000 0000000F

StackWalk failed (error 299)

EAX:00000033 EBX:05C1F910 ECX:0212A7B0 EDX:020BEAD2 ESI:00000000 EDI:0215E3F0
EIP:004B3710 ESP:05C1F8A4 EBP:73212881
CS:0023 SS:002B DS:002B ES:002B FS:0053 GS:002B

Windows Ver: NT 6.1 Build 7600
DDraw Ver: 6.1.7600.16385
DSound Ver: 6.1.7600.16385

Product: Product
Time Loaded: 00:00:02
Fullscreen: No
Primary ThreadId: F18

Joined: 11/29/2009

Please upload your level somewhere so we can check for errors.

Author of World of Goo Portable. Download here!

Joined: 04/24/2010

Thanks for the quick response! Any suggestions on where I can upload it? I'm guessing I shouldn't upload it here as GooFans wouldn't want to be bombarded with test levels?


Joined: 11/29/2009

MediaFire? That's the best place I know to upload.

Author of World of Goo Portable. Download here!

Joined: 04/24/2010

I uploaded the level to MediaFire. You can access it at:

I hope this works and I hope I uploaded the right file. If anyone has an idea why I'm getting the error please let me know.


Joined: 06/19/2009

Hmm... Your level works OK for me!

Try loading one of the original levels into the editor, don't change anything, and just Click Save N Play... what happens?

Joined: 04/24/2010

Thanks for the idea. I think I've solved the problem. This is my son's computer (6 years old) and he is set up as a standard user in Windows7. Once I gave him administrator access it seems to have solved the problem. So now we're able to test/play the level.

One more question: how do I get a level we create to show up in Goo Tools and therefore play directly out of the game rather than the editor? I've copied the files to the res/levels diectory, but it doesn't show up in Goo Tool.

Thanks for all of the help!

Joined: 06/19/2009

Gootool uses files call "goomod", you will need to make one for your level.
Load your level into WooGLE, and click the Make .goomod button (next to save and play)
Save the file somewhere, then find it through Computer or Explorer and double-click it. That should start Gootool and add your level to the list of add-ins.
When you click Save, GooTool will include it in the modified game folder, and your level should appear in Chapter 1, just like any you've downloaded.