(FIXED, IGNORE THIS) Every Copy of World of Goo Closes/Crashes on startup

3 replies [Last post]
Joined: 07/06/2014

The second post describes my current predicament.

EDIT: another dumb solution, this time restarting

I was playing Tumbler, and completed a level. When I finished the level, the game closed, which was somewhat disappointing. I clicked the refresh button in GooTool to make sure it was displaying accurate information. Afterwards I clicked the button in GooTool to relaunch WoG, but as soon as it started to open I was presented with a "Fatal Error" box (before the main game window even appeared). I tried restoring my profiles to an earlier state, and I also disabled all addins. But World of Goo still would not open without throwing a fatal error.

For reference, here's the error message I get:

Exception: Access Violation (code 0xc0000005) at address 0047F9DF in thread 1D8
Module: WorldOfGoo.exe
Logical Address: 0001:0007E9DF
0018FF84 0047F9DF 0001:0007E9DF WorldOfGoo.exe
Params: 7FFDE000 0018FFD4 777CBF39 7FFDE000
StackWalk failed (error 299)
EAX:00000000 EBX:00000000 ECX:006908B0 EDX:00250E58 ESI:022972E8 EDI:002427F0
EIP:0047F9DF ESP:0018FE5C  EBP:0018FF84
CS:0023 SS:002B DS:002B ES:002B FS:0053 GS:002B
Windows Ver: NT 6.2  Build 9200

I run the game on Windows 8. Even if I have to delete the directory and recreate it from scratch, I'd at least like to know what went wrong because I really don't understand how it could have been broken.

UPDATE: For some reason, playing the original copy of the game through Steam seems to have fixed the issue.

My Top 5 tower[s]: 51.38m Profile | 51.17m Video - Click on my username to see my addins.

Joined: 07/06/2014

Okay, World of Goo seems to want to give me as much grief as possible. At one point I got the issue of "world of goo closes on startup". I found a solution that worked. The game would lag a lot under certain circumstances but I could work with it. Now the insta-close issue is back again (with the former solution already in place) and I'm tired of this issue. It affects every copy on my system and there is no other help about this problem on the internet Angry If anyone can help provide a fix it would be GREATLY appreciated.

(I am running WoG on a windows 8 computer, with the game in compatibility mode for Windows XP Service Pack 2, which was necessary to fix it the first time)

My Top 5 tower[s]: 51.38m Profile | 51.17m Video - Click on my username to see my addins.

Joined: 07/05/2011

Disable the compatibility mode. I'm using Windows 8.1 and it works fine.

If it still doesn't work, try reinstalling your game.

If it still doesn't work, try renaming your profile file so the game could create a new one and see if it works.

Joined: 07/06/2014

Thanks for the help Smile I'll try to remember this for the future.

Now I can try to improve my towers Laughing out loud

My Top 5 tower[s]: 51.38m Profile | 51.17m Video - Click on my username to see my addins.