World Of Goo Error: Proven it is because of GooTool!

7 replies [Last post]
Joined: 05/26/2009


Exception: Access Violation (code 0xc0000005) at address 00433C48 in thread 8C0
Module: WorldOfGoo.exe
Logical Address: 0001:00032C48
029F3110 00433C48 0001:00032C48 WorldOfGoo.exe
Params: 005CF904 C1000000 40A00000 005CF904
StackWalk failed (error 0)
EAX:00000000 EBX:029F3170 ECX:00000000 EDX:35AF0008 ESI:0219FD1C EDI:029F3134
EIP:00433C48 ESP:0219FCF8  EBP:029F3110
CS:001B SS:0023 DS:0023 ES:0023 FS:003B GS:0000
Windows Ver: NT 5.1 Service Pack 3 Build 2600
DDraw Ver: 5.03.2600.5512
DSound Ver: 5.3.2600.5512
Product: Product
Time Loaded: 00:00:06
Fullscreen: No
Primary ThreadId: 484
This has happened before with gootool, i was about to play someone's level when, during the loading sequence, that fatal error popped up. So, i uninstalled and re-installed gootool. It worked. Now, im VERY disappointed, because it did that to me AGAIN just now-with my own addin! I disabled the addin, loaded WoG-it worked. So, i've proven it is not the addins-but gootool, that made the error.

OVER 9000

Joined: 11/04/2008

Not sure how that proves that it isn't a problem with the addin. Can you e-mail me the goomod file?

Joined: 05/26/2009

nvm, i found out it was my edited [ball.xml.bin] that would have "supposedly" fixed the problem where the timebugs don't have eyes. You can lock topic.

OVER 9000

Joined: 06/28/2009

the goo tool doesn't say it's 100% garenteed to work, but knowing about the error is helpful, thanks!

WoG2 Shall Prevail!

Joined: 09/21/2009

I get the same error whenever I "save and launch" world of goo from goo tool

Exception: Access Violation (code 0xc0000005) at address 0047F9DF in thread 1BFC
Module: WorldOfGoo.exe
Logical Address: 0001:0007E9DF
0017FF88 0047F9DF 0001:0007E9DF WorldOfGoo.exe
Params: 7EFDE000 0017FFD4 778ECFED 7EFDE000
StackWalk failed (error 299)
EAX:00000000 EBX:00000000 ECX:02A20AD0 EDX:002D0E58 ESI:025E62B8 EDI:002C27F0
EIP:0047F9DF ESP:0017FE60  EBP:0017FF88
CS:0023 SS:002B DS:002B ES:002B FS:0053 GS:002B
Windows Ver: NT 6.0 Service Pack 1 Build 6001

I tried "save and launch" before and after installing any add-ins, and I get the same error.


Joined: 07/10/2010

I have this error,the 299 i can't start the chapter 1, what can i do?

Tongue K@RW@

Joined: 11/29/2009

Modded or unmodded? If unmodded, reinstall and update your graphic and sound drivers. If modded delete your modded version, upgrade GooTool, and try again.

Author of World of Goo Portable. Download here!

Joined: 07/10/2010

I unistall it and the game, so i install the game and i made my profile again and when i install goo tool it show the profile that no more exist and don't lauch the game. make me and error that i put in,

Tongue K@RW@