can't open gootool 1.1

18 replies [Last post]
Joined: 07/21/2009

I installed new gootool and tried to open it, but there is an error:
"Uncaught exception (java.lang.NullPointerException):

earlier version of GooTool was ok, error appeared with 1.1.
I won't post any log file, because I can't find it anywhere.

Joined: 07/21/2009

sorry, it's

Joined: 09/01/2009

I had same problem. At end of these posts is Mr. Croft's explanation:
It seems to be caused by GooTool not automatically finding your pers2.dat profile.

Joined: 07/21/2009

So what should I do?

Joined: 09/01/2009

Sorry. I should've said this in the beginning:
Find your pers2.dat file and copy it to where GooTool can easily find it, that is in windows XP:
C:\Documents and Settings\(your name)\Local Settings\Application Data\2DBoy\World of Goo\
and in Vista:
C:\Users\(your name)\AppData\Local\2DBoy\World of Goo\
You might have to create the 2DBoy and World of Goo folders in each case.
I'm not sure about other operating systems.
Hopefully after this, GooTool will launch successfully and you can change where it looks for your pers2.dat file, so you don't have this problem in the future.
Goo-d luck!

Joined: 07/21/2009

I can't find that pers2.dat file, where should it be?

Joined: 09/01/2009

Oh. I don't know. What version of Windows (if you are running Windows) are you running?

Joined: 07/21/2009

I've got XP with, I think, all updates

thB's picture
ContributorAddin AuthorKleptomaniacToo Much Free TimeSerious OCD
Joined: 04/17/2009

Just hit Win+F then and do a search for "pers2.dat" (without the quotes) across all your hard disk drives.

my gooey profile | my video channel | author of Hazardous Environment

Joined: 07/21/2009

It seems I don't have that file on my computer. Like gootool's logfile. Can't find both.

Joined: 03/31/2009

You must have 'View Hidden Files and Folders' option turned ON is Control Panel/Folder Options Wink

My Gooish profile | Videos on YouTube | My WOG Mods

Joined: 09/01/2009

Or Tools menu->Folder Options->View tab ->Show Hidden Files and Folders button.

Joined: 07/21/2009

I was sure that I had this option ON, but I was wrong.

stil doesn't work. I copied it to couple of places, but I've still got this this problem.

Joined: 09/01/2009

You copied it to C:\Documents and Settings\(your name)\Local Settings\Application Data\2DBoy\World of Goo\ and it still doesn't work? That's really strange. I've reached the end of my guessing problem solutions here.

Joined: 04/10/2009

i created an online id on unusable profile,then all profiles data dissapeared from gootool.Every time i try to open it,it says "Uncaugth exception (java.util.NoSuchElementExpection) null"

Crazeh man!

Joined: 09/01/2009

That sounds like a similar message, but not exactly the same. The problem here is most likely GooTool not finding the pers2.dat file.

Joined: 11/04/2008

This bug is fixed in GooTool 1.0.2, out any minute now.

Joined: 07/21/2009

New version of Gootool works ok, thanks!

Joined: 11/11/2009

hey thanks for these tipps its working at my laptop too now ^^

Did u found an error? Keep it yourself! ^^