Big Mistake: putting the 1.30 patch on WoG 1.30

3 replies [Last post]
Joined: 01/19/2009

(WoG crash, GooTool access denied)
When i tried to figure something out, and wasn't exactly sure if i really had WoG 1.30, i downloaded the patch and installed it.
Stupid me.

Now, i can't start the original WorldOfGoo.exe (crashes with the Vista "windows can search online for a solution" dialog)
When i start it with administrator rights, it works, but the profile is wrong, no OCD flags and only chapter one completed. maybe it finds the one from the WoG Demo...

and GooTool complains about:
"Error reading current configuration: C:\Program Files(x86)\WorldOfGoo\properties\config.txt (access denied)",
and when i start that as administrator, there are no addins, and no custom folder specified, and it also finds that profile with only a few levels played.

WTF did that patch do?

| Fly Her to the Moon (with Antigravity Goo) | Infinitive Windows Freezer (unlimited Goo playground) |

Joined: 01/19/2009

ha,ha, Brush! you better help me find out the solution, instead of changing the title. Wink Laughing out loud

| Fly Her to the Moon (with Antigravity Goo) | Infinitive Windows Freezer (unlimited Goo playground) |

Joined: 06/19/2009

hehe... Well I'd try it here, but doesn't sound like a good idea.

I wonder if the problem is not... re-patching 1.3
but patching to v1.3 when you've never had v1.0 (or whatever) installed.

I know the patch copies your profile from the "old location" to the "new location"

Maybe it has copied it from the "old location" again... and if that old profile was from the demo, or a "long long time ago..." it might not check if it was overwriting... and just drop in the old one.

I wonder what it does if there's no profile in the "old location" when it tries?
Maybe generates an "emergency-default" profile instead? Puzzled

Also I think the patch modifies / replaces the config.txt file (to allow the refresh rate entry?)
What if it tries to modify an "already modified" config.txt? Puzzled

Check your config.txt... maybe post it

Joined: 01/19/2009

yeah, you're having some good thoughts there, thanks.^^

lol. trying to open up the config.txt "Access denied"
also there is a config.txt.old file, i have no idea if that were there before patching.

<!-- IMPORTANT WARNING: If you edit this file, your computer will probably explode. Your friend, the High Resolution Sign Painter -->
	<param name="language" value="en"/>
	<param name="screen_width" value="800"/>
	<param name="screen_height" value="600"/>
	<param name="refreshrate" value="60" />
	<param name="ui_inset" value="10"/>

edit: i think i found the problem: config.txt has only SYSTEM, administrators and my admin account in the security/rightsmanagement tab.

another edit: i put in Benutzer(Users), and now am able to open it (it's the same as in config.txt.old). but GooTool still get's the denied message.

final edit: it works again!
i had to change the "owner" of config.txt from administrators to my windows profile.
now gootool and worldofgoo.exe work again like they should, with my normal profile. Smile

| Fly Her to the Moon (with Antigravity Goo) | Infinitive Windows Freezer (unlimited Goo playground) |