Custom pipes?

25 replies [Last post]
Joined: 03/13/2012

I read the "custom pipes" post describing the creation of a new pipe, followed the steps correctly and still cant get a custom pipe. Help!

Because writing signatures is too mainstream

Joined: 09/01/2009

Well, what doesn't work? What steps did you take, where did it stop working, are you using the latest version of the editor, etc.

It's difficult to offer any help when we aren't given any information to go on. Wink

Joined: 04/17/2011

Oh, mine, MOM this is not something to ask others - they won't understand you and you won't understand them - give an examples of what could have happened like:

Do you know when you are trying to save or/and make a goomod of your level? If so it should say for your custom pipe how you should name the pipe parts (Rename them on resources). Name them as the window (Which opens usually when you want to make a goomod of your level) says and it'll work fine.

If it still don't work check if you have the latest version of the WOOGLE cause WOG only accepts the latest versions (Somehow).

If it still doesn't work check if you done all right. If you checked and it still doesn't work it should be some kind of bug - in that case you close your WOOGLE and open it again or delete it and install again but don't worry - all the levels will be in the editor if you install it again while you have your gootool Smile

Joined: 09/01/2009

I'm sorry, Wiki, but I don't understand what you're asking nothinggoo. And I don't believe your questions are relevant, either. Please, please, please don't try to help others when you have no clue yourself. I know you're just trying to be helpful, but all you've done so far when trying to help in the past is mislead the people who are already confused. It's not helping.

Joined: 03/13/2012

Well what i did:
1. Copied the black version if a pipe and modified it to make it look vivid blue
2. Renamed the pipe images from "whatever_BLACK" to "whatever_RADIOACTIVE"
3. Pasted the new pipe into the res/images/levelimages
4. Pasted the images into the level folder
5. Tried to access the pipe from the editor
6. PROBLEM: pipe did not appear in the "type" parameter.

Did i do something wrong? If so can you tell me what i did? i seem to be using the latest version of the editor.

PS. Thanks for the quick answer Smile

Because writing signatures is too mainstream

Joined: 09/01/2009

Ah, yes. If you read the page carefully, you'll see that WooGLE won't automatically detect the pipe is there. But you can still type in the pipe name in WooGLE under the "type" field, and it will work properly when you go to play the level.

Joined: 03/13/2012

OK i'll try right now!

Because writing signatures is too mainstream

Joined: 03/13/2012

Something is wrong. It says that the resources are not there. Do you have to make a new folder for them or something?

Because writing signatures is too mainstream

Joined: 04/23/2011

You'll either have to import those images into your WooGLE level, or go into the resources.xml.bin dycrpt that and add your images in the text file.

For those wondering, Earth of Goo is still being worked on, but not as often. It will be finished! Check out my website/YouTube www.coloradocontraptions.weebly.com !

Joined: 03/13/2012

Hmm....I imported them into the level, and the error message got even bigger - unused resources. dunno why....

Because writing signatures is too mainstream

Joined: 09/01/2009

Have you named the resources properly inside the level editor? Also, are they in the folder you think they're in? The only reason (afaik) that WooGLE would complain about missing resources would be because they aren't there.

AFAIK, unused resources is a warning message, not an error message. You can ignore it.

Joined: 03/13/2012

They are in the level folder, so /res/levels/{levelname} however, what i found out that the name changes from IMAGE_GLOBAL
to IMAGES_{LEVELNAME}_IMAGE GLOBAL could that be the problem? And the error is critical, i cant run the level
***EDIT****
I renamed the images a little and got the game to work without an error message. however, the pipe displayed is still black. What did i do wrong?
***EDIT 2***
could that be a bug for level editor? maybe if i make a goomod the pipe will be blue?

Because writing signatures is too mainstream

Joined: 04/23/2011

I don't know... I never encountered that problem... hmmm... If you modified your resources.xml.bin file you need to make sure that the text for pipe type matches the other text pipe types and that when you type it into the editor, the pipe type has to be in all CAPS but other than that I don't know what your problem could be... Puzzled

P.S. Is your pipe really called radioactive? Because I was gonna use that idea in Earth Of Goo along with radioactive balls!! Tongue

For those wondering, Earth of Goo is still being worked on, but not as often. It will be finished! Check out my website/YouTube www.coloradocontraptions.weebly.com !

Joined: 09/01/2009

When in doubt, follow the spec http://goofans.com/developers/world-of-goo-level-editor/reference-guide/... .

The images should have those names (Not certain if it'd cause it not to work or no), but the important thing is that the id in the resource window be in the form IMAGE_GLOBAL_PIPE_{PIPENAME} (for the pipe segment; read the spec for the other images). Otherwise, it simply will not work.

nothinggoo wrote:

what i found out that the name changes from IMAGE_GLOBAL
to IMAGES_{LEVELNAME}_IMAGE GLOBAL could that be the problem?

Yes, that is the problem exactly. Change it back. You can change the id field directly.

Also, unused resources is a warning, not an error, like I said. I double-checked. If you're getting a critical error box, post the whole contents of the box here so we can see, because the unused resources aren't causing the error.

Joined: 03/13/2012

oh great! let me try again now...
Smile :) Smile

Sorry but i am also making radioactive balls. And trying to make a pipe. Tongue Some are almost the same as the original balls but have 4 strands, some are completely different (and they are all using custom colours)

It was not the unused resources that caused the error, but the MISSING resources. That does not happen anymore. Smile

Because writing signatures is too mainstream

Joined: 09/01/2009

Ok, missing resources is something different entirely. It means there were some images that were supposed to be there but weren't. Wink

By the way, rather than triple-posting, please use the "Edit" button on the bottom of your posts. Thanks. Smile

And it's perfectly ok if you both create radioactive Goo Balls, but be sure to not name them something generic like "radioactive" or something. Name them "nothinggoo_radioactive" and "GooballsOfFire_radioactive" or something like that to avoid name collision errors. Smile It's a really good idea to do this with every Goo Ball you create, and even every level you make.

Joined: 03/13/2012

Oh sorry about the triple posts. I did everything like you said, but the pipe is still black. ALL the resource names and paths are the same as the ones i the article you sent me. I have no idea about what could be wrong. I also downloaded the custom pipe demo and looked in it, and found nothing useful. Any more ideas? Sad Sad Sad

Because writing signatures is too mainstream

Joined: 09/01/2009

Hmm, weird. Package it up into a goomod and upload. I'll take a look at it.

Joined: 03/13/2012

Sure. The resources will all be there, and if it is a very stupid mistake of mine please dont laugh - i am still very bad at this Smile
EDIT
ok its on the unpublished add ins i did not request it to be published though

Because writing signatures is too mainstream

Joined: 09/01/2009

No problem. That's how life goes. Smile
Oh, and we can't see the unpublished addins. Link please?

Joined: 04/23/2011

Well... I already have my balls named and somewhat under construction... that makes it hard for me to change the names! Puzzled However, they are named: RadioactiveBall and RadioactiveProduct with capitals, so If nothinggoo names his/her balls LOWERCASE or with a nothinggoo in front like you said it should be good...

Description of my Radioactive balls so we can keep them different enough... Tongue

They are BRIGHT BRIGHT neon yellowish balls that have eyes and when popped release RadioactiveProduct Balls and can be built with... (I think 4 strands and detachable) but they also have a decay which will kill them if not used fast enough. (As radioactivity is very unstable)

The RadioactiveProduct balls are bright neon GREEN and very small and basically useless except for collecting extra balls in the pipes and seeing in very black levels...

Hope there are some differences so we can figure out whose are whose... Laughing out loud

For those wondering, Earth of Goo is still being worked on, but not as often. It will be finished! Check out my website/YouTube www.coloradocontraptions.weebly.com !

Joined: 03/13/2012

It is okay, my goo balls are called the RadioactiveBall{color} and there are a lot of different colors. as long as you dont use these names along with the ShadowAnchor and Silveballglow (silve was my spelling mistake) and RadioacticeBallPilot it will not make any errors. But more goo is to come! Smile
EDIT
never mind MOM4Evr my pipe works now Smile its vivid blue. and awesome. Thank you all for your help! Smile Smile Smile Smile Smile Smile Smile Smile Smile Smile Smile Smile Smile Smile Smile Smile Smile Smile

Because writing signatures is too mainstream

Joined: 09/01/2009

No problem! I'm glad that cleared it up! Smile

And looks like there will be no name conflicts here, but in the future please prefix your Goo Balls with your username and we won't have to worry about anything. This goes for everybody. Smile

Joined: 03/13/2012

@ gooballsonfire Ha ha ha nice! Well, my goo does not die, but i was just about to use the mini goo idea - is it okay if i still use it? OH and one of my gooballs is also yellowish, but does not have eyes, so we should easily figure out whose they are. And about the RadioactiveBall - my goos use the same prefix, but end with some other thing.

Because writing signatures is too mainstream

Joined: 04/23/2011

Ok... that's fine! ;)Gotta pack now for tour! Laughing out loud

For those wondering, Earth of Goo is still being worked on, but not as often. It will be finished! Check out my website/YouTube www.coloradocontraptions.weebly.com !

Joined: 03/13/2012

Wikigoo-4evr wrote:
Oh, mine, MOM this is not something to ask others - they won't understand you and you won't understand them - give an examples of what could have happened like:

Do you know when you are trying to save or/and make a goomod of your level? If so it should say for your custom pipe how you should name the pipe parts (Rename them on resources). Name them as the window (Which opens usually when you want to make a goomod of your level) says and it'll work fine.

If it still don't work check if you have the latest version of the WOOGLE cause WOG only accepts the latest versions (Somehow).

If it still doesn't work check if you done all right. If you checked and it still doesn't work it should be some kind of bug - in that case you close your WOOGLE and open it again or delete it and install again but don't worry - all the levels will be in the editor if you install it again while you have your gootool Smile

Wait, i just figured. This post was the solution, but we could not understand it. He says, that when we make the goomod and get anerror message, you should rename the part in recourses to match the id. That was easy! And the questions WERE relevant.

Because writing signatures is too mainstream