World of Goo Fatal Error

3 replies [Last post]
Joined: 12/16/2010

I keep getting the same error everytime I try to start World of Goo, it freezes while the white text is scrolling up the black screen at the beginning. I downloaded and installed the game through the game for windows live client, it ran fine 2 or 3 first times I started it but ever since then I have been unable to play. This is the error message:

Exception: Access Violation (code 0xc0000005) at address 66666326 in thread 18C4
Module: MSVCP90.dll
Logical Address: 0001:00005326

0012F93C 66666326 class std::basic_string,class std::allocator > & std::basic_string,class std::allocator >::assign(class std::basic_string,class std::allo+10
Params: 00000134 00000000 FFFFFFFF 0094239B

StackWalk failed (error 299)

EAX:00000000 EBX:0012F988 ECX:0012F988 EDX:00000000 ESI:0012F988 EDI:00000134
EIP:66666326 ESP:0012F930 EBP:0012F93C
CS:001B SS:0023 DS:0023 ES:0023 FS:003B GS:0000

Windows Ver: NT 6.0 Service Pack 2 Build 6002
DDraw Ver: 6.0.6000.16386
DSound Ver: 6.0.6000.16386

Product: Product
Time Loaded: 00:00:05
Fullscreen: No
Primary ThreadId: 18C4

I am running Windows Vista fully updated. I have tried running the game as an administrator and with several different compatability modes but nothing has worked.

Joined: 09/01/2009

Wow, that is odd. Do you remember if you did anything between the time it was working and the time it stopped working?
You may want to try installing the patch; not sure if it'll solve your problem or not, but it's worth a shot:
I couldn't quite understand; where did you get World of Goo from?

Joined: 12/26/2010

Almost Thinks have me Fatal Errors!

Like:Collerful Drained,Tacoman13 view of the World of Goo Demo

I Deleted of the list of GooToll to Resolve Problems

Joined: 11/30/2010

dudes i serously hate to tell you this but i had this problem and i just reinstalled wog but seriously just find another way first.

get my first theme here:
it is called ivygreen