touchscreen off running linux ubuntu 10.10

10 replies [Last post]
Joined: 01/13/2011

Hello, It seems as if the game and my computer aren't in alignment. My touchscreen is accurate with everything but WOG. It has my finger over an inch off the mark. Is there anything I can do to adjust the settings so that this will work? My screen res is set at 1024 x 600, ( that is as high as it will go), and I tried 800 x 600 with no luck. I am guessing it is something inside the program that needs tweaked?

Any help would be much appreciated!

Thank you


Joined: 12/23/2010

Wow. I'm not sure what it could be. Most likely it is a kind of bug or something hard-coded in the game, but I wouldn't know how to work around it.

Anyway, someone else might know. I just have a question: do you mean you're using an actual touch-screen on your PC, or do you mean a graphics tablet?

Joined: 01/13/2011

I'm using an actual touchscreen (an Asus t101mt netbook tablet). It would make the game way more fun to be able to grab those little goo balls with a stylis!

Is there anyway into the code to tweak the display settings?

Joined: 09/01/2009

You can try modifying the display settings in config.txt, at least somewhat.
Problem with my stylus is that it has a slight delay when grabbing Goo Balls, which makes it slightly annoying to use... besides the fact that you can't throw them very hard at all. But it is cool.

Joined: 01/13/2011

hi, thanks!

could you elaborate on how to do that?

Joined: 09/01/2009

config.txt is (on my computer at least) at /opt/WorldOfGoo/properties/ (of course you'll need to use sudo commands to edit it). It's fairly well-commented and self-explanitory, so what exactly do you want to change?

Totally forgot to mention: the easiest way to change resolution and such is inside GooTool itself, under the "Options" tab. That may be more forgiving than editing config.txt directly.

On a side note, there is a possibility, documented in config.txt, that you may be able to use multitouch or multiple mice to play WOG, but I've never gotten it to work. Maybe I'll try again sometime...

I've never really gotten a stylus to work with WOG running fullscreen in Linux, Kubuntu doesn't seem to like a stylus with a fullscreen application running, so it may be worth a shot to see if running the game windowed will work any better for you and your touchscreen. (Just the standard keyboard shortcut Alt-Enter)

Good luck!

EDIT: Woaz, no delay at all with my stylus when running windowed like I thought there was. It works great. This is fun!

Joined: 01/13/2011

Hmm, even more confused now. haha! my display settings are 1024x600 (thats as high as it will go). looks like the goo is set at 800x600. Tried just changing the settings but no luck. Apparently, I was supposed to do the sudu thing after, which I'm not sure what to do there. Nor do I know where to access wog tools.

Are you talking about running a windows version of goo through wine which is working for you now?

Joined: 09/01/2009

No, are you running the Windows WOG from Wine? I'm using a Linux build of WOG from the Humble Indie Bundle.
If you don't have the full version of World of Goo for Linux, you can always just download the demo from 2dBoy's site and copy over the res folder from your Windows version. Should work fine after that.

GooTool can be accessed from this site. Look at the green buttons up top. After you download it (you'll have to have Java installed also), you can just change resolution from there.

Ok, so are you new to sudo commands? Pop open a terminal window, type "cd /opt/WorldOfGoo/properties/", then type "sudo gedit config.txt". After entering your password, you should be able to edit without a hitch. But changing resolution in GooTool is far easier.

Joined: 01/13/2011

I tried changing the res in the goo tool to match my display settings of 1024x600 and it seemed to make it worse. I am running the full version on linux. I just didn't understand what you meant by windowed. You mean running it in a window form wear it doesn't take over your whole computer like mine does? how do you do that?

Anyway, does your WOG always have black unused space on both sides of the game? With my 10" netbook it takes up probably an inch or more on each side. I think this is why the touch is so far off.

Joined: 01/13/2011

no need to answer any of that last post. i figured out how to put into windowed mode (alt+ent when the game is starting).

and PRESTO! Weeeeeeeeeeee, this is gonna be fun!

thank you sooooo much!

Joined: 09/01/2009

(Wonders if he even read my last couple posts)

Ok, glad it's working now for you! Have fun!
The gap around the edges _could_ be caused by having your screen set as if it's trying to display across a different monitor, I know mine has a gap around the edges in Windows when I have that set. This can be toggled by Fn-F10 (at least on my comp, yours may be different.)

But as long as you have a solution that's working for you, that's great!