Multi-monitor error

7 replies [Last post]
Joined: 06/06/2011

I began playing WoG when I had only one monitor and had been loving it. Ever since I installed a 2nd monitor, I have not been able to play WoG at all.

It appears that when WoG launches, it cannot figure out which monitor to display on. It quickly tries to adjust my screen resolution, which flickers both of my monitors, and then enters full screen and exits again... all of this VERY quickly, and then continues to do this in a never ending loop. It's a very dizzying and ultimately non-productive experience. All I can do when this happens is to end the WoG process via Task Manager, which is very tedious when my screen resolution is constantly being bounced around.

As this is one of my favorite games, and I can no longer play it... please help! =)

Joined: 09/01/2009

My best recommendation (if you want to play the game fullscreen) would be to disable the monitor manually in Control Panel (I think you can do this; if you can't, you may just have to unplug the monitor) every time before you play the game. This sounds more like some kind of DirectX problem than a problem with the game in general. Did you get a new graphics card when you got your monitor? If so, you may also want to double-check and see if you have the latest drivers for your card and if someone has had similar trouble when playing fullscreen games.

As a simpler alternative, you can always play World of Goo windowed. It has its own quirks with mouse handling and stuff, but it's still playable. Edit the config.txt file in the World of Goo directory in the properties subfolder, or install GooTool and disable fullscreen. You can also try pressing Alt-Enter when you boot up the game to switch it to windowed mode. This last option may or may not work, however.

Remember also that you ought to be able to press Alt-F4 to close World of Goo, without having to worry about opening Task Manager each time. Wink

What version of Windows do you have, by the way?

Actually, come to think of it, do you have to find the "World of Goo.exe" process in Task Manager to close it, or can you find it in the list of running programs in Task Manager?

Joined: 06/06/2011

Just bought the game and had the exact same issue. I tried GooTools but changing the resolution didn't work for me. Then I went into my nVidia graphic control panel, disabled the second monitor, and now it works fine. Would have preferred to keep the dual monitors but oh well. This is the 1st game that has an issue with it.

Joined: 09/01/2009

Changing the resolution in GooTool wouldn't solve the problem; you'd want to use GooTool to disable fullscreen. Sorry if I didn't make that very clear.
But yes, unfortunately, the only solution I can think of without disabling fullscreen is disabling the second monitor. I may try fiddling around with it myself and trying to reproduce the problem, but it might be graphics-card dependent.

You could try contacting 2DBoy about the problem and seeing if they'll submit a patch for it: but I kind of doubt they'd respond. Worth a shot if it really annoys you, though.

Another possibility is that you could dig around in your DirectX settings some, too, but there's no guarantees with that either, and I can't really help you there.

You said this is the first game you've had that trouble with; what games work fine for you?

Joined: 06/06/2011

okay, I just don't see any 'disable fullscreen' mode in GooTool. I just downloaded v

Dual screen ok games - Civ5, Atom Zombie Smasher, Half Life 2, World of Warcraft, Fallen Earth, X-Com, Age of Conan, Medieval War 2, Empire Total War

Joined: 01/07/2010

maybe the drivers are not updated, as well only unplug or disable manually the 2nd monitor as MOM said.
It could a problem of out-put.The monitors are not well configurated.
But for not be such a problem only disconect the 2nd monitor and talk what happened

Hey You!
Start the fun and Install the fan made CHAPTER 6: MOON OF GOO

Joined: 03/31/2009

You can disable fullscreen by pressing Alt+Enter but its not recommended because its makes the games harder... (try it and you'll see what I mean) The best way to solve this is by temporarily disabling one of your monitors in control panel.

My Gooish profile | Videos on YouTube | My WOG Mods

Joined: 02/20/2011

i know what you mean, Azuresky. I just got a cool new monitor too and I have that problem.
It had a stuck pixel and I sent it to California to get a new one, so the problem's temporarily fixed ( only one monitor for the time being)