Fedora 17 - 64 bit

6 replies [Last post]
Joined: 06/13/2012

So I installed the RPM, but when I try to run the game, it simply hangs and will not run, the WorldofGoo.log is blank.

Any suggstions?

Joined: 09/01/2009

Hi, korbel!
Have you looked at http://goofans.com/forum/world-of-goo/support/3529 and http://goofans.com/forum/world-of-goo/support/3581 yet? It may be the same problem.

Are you getting any output when you run from the terminal?

Joined: 06/13/2012

No it is not the same issue, a segment fault is something, I am getting nothing. I run it from the terminal and it just sits. It does nothing. No error, no progress. I let it run over night to see is maybe it will error out but it doesn't

Joined: 09/01/2009

Wow, that's really strange. Sorry; I dunno. Aside from contacting 2DBoy via http://www.2dboy.com/contact.php I have no idea. Where'd you get your copy from?

EDIT: I was just chatting on IRC with a Fedora 17 32-bit user who was having a similar problem. For him, "sudo yum -y install libogg SDL SDL_mixer libvorbis" and then running the executable directly (bypassing the shell script) works.

Joined: 06/18/2012

Same problem here. Seems I already had libogg SDL SDL_mixer libvorbis packages installed and newest version. Running the executable directly did help in the sense that the screen went blank for a bit and then I was back at the shell with my display set to 800x600.

Joined: 06/30/2012

Had the same problem on fedora 17 - 64bit
I followed this step, and it worked.

Joined: 08/24/2012

I just ran into this problem on Fedora 17 64-bit, and found that magnus' link worked nicely. I'm re-posting the solution here to ensure that solution is always available on this site. Thanks, magnus (and others)!

download these 3 files:

and replace those in

gksu nautilus /opt/WorldOfGoo/libs64/
gksu nautilus /opt/WorldOfGoo/libs32/