Game Won't Luanch

6 replies [Last post]
Joined: 07/30/2012

When I try to launch World of Goo, through Steam, the dialog box saying the game is starting pops up for just a split second, and then it disappears but the game does not launch. I don't get an error message or anything; nothing happens.

I'm on Windows 7.

Any idea what's going on? I've restarted Steam, but it did not fix my problem.


Joined: 08/06/2010

Hm. If it's on Steam, try uninstalling and reinstalling, or, if this is an option for WoG (I don't have a Steam copy), right-click it in the list, bring up Properties, and verify the integrity of the game's files.

Another Planet finally has an official release! Download chapters 1 through 3 here! Thank you for waiting so long while I kept starting over.

Joined: 07/30/2012

Just deleted and re-installed it. No change.

Joined: 12/23/2010

Have you tried launching WoG directly from its .exe? It should be located in [Steam Root]/steamapps/common/worldofgoo (or something similar).

If that works then we can conclude that it's a problem with Steam, otherwise there's something weird going on with WoG itself.

Joined: 07/30/2012

Remarkably, that worked. There must be some problem with Steam. Thanks!

Joined: 12/23/2010

Glad to know that it worked! That's weird though, I don't know why it wouldn't work with Steam.

Joined: 12/29/2008

That reminds me, I also tried running world of goo through steam, when it didn't work, I didn't really take notice. There must be an issue with Steam.

Check out my SoundCloud, MomoSoundWaves