Nasty Screen Flicker after OS and hardware upgrades

9 replies [Last post]
Joined: 02/01/2011

Was running Windows 7 32-bit, switched over to 64 bit. Then upgraded motherboard, cpu, RAM and graphics. Then reinstalled WoG. The game now flickers like an old time movie, so bad I can't stand it. Installed the patch, no change. Any suggestions?

Joined: 07/08/2011

Reinstall again? If the problem persists after that, try getting it from another source.

Also specify where you got the game and what version of Windows 7 you have. This information would help.

Joined: 02/01/2011

Got the game from the 2D Boy site, running Windows 7 64-bit Home Premium. I'll try uninstall/reinstall, thanks.

Uninstall/reinstall unsuccessful. Sad Uninstalled again and installed demo, but has the same issue.

Joined: 07/08/2011


The demo didn't work either you say...

It's most likely something to do with your specs. Maybe list them?

Joined: 09/01/2009

Hmm. Did you make sure that you're using the latest graphics drivers? Flickery screen sounds like a double-buffering problem, but I've only ever had that on a lame graphics card on Linux.

Joined: 12/23/2010

Has anybody considered the fact that seashelly is using 64-bit Windows after previously having 32-bit? The OP hints that WoG worked before the switch.

But I'm not sure if there are specific versions of WoG for each type. If so, then that's the problem. If not, then has it been said that it works on 64-bit OSs?

Joined: 02/01/2011

RedTheGreen, both versions work, but with wicked screen flicker, almost like strobing. I tried playing around with Windows Program Compatibility whatever without success, but will try again.

Processor: AMD A4-3300 APU
Memory: 16 GB DDR3
Graphics: AMD Radeon HD 6450, 8696 MB total available graphics memory


Joined: 07/08/2011

Oh, you say you upgraded to 64-bit afterward. Are you making sure to install in "Program Files (x86)" and not "Program Files"?

Joined: 02/01/2011

Well, for now the problem is solved, or at least on the back burner. Sometime between shutting the 'puter off last night, and attempting to turn it on this morning, the graphics card stopped working. Actually, the whole dang thing wasn't booting. But that's fixed now, and the offending card removed. The little goo balls, along with everything else in the game, is behaving as expected.

We'll see what happens when the new graphics card arrives. And yes, the game was/is installed in "Program Files (x86). I'd been wondering about that myself. Until just a short while ago.

*Update: I think maybe AMD Crossfire is not Goo friendly. I started having the same problem with the new graphics card, but after disabling Crossfire everything in the game behaved normally.

Thank you again for the suggestions.

Joined: 09/01/2009

Hmm, so Crossfire and Goo don't mix. Good to know. Thanks for the update, and I'm glad you managed to solve the problem! Smile