Resolution and performance problems in Linux

12 replies [Last post]
Joined: 03/25/2013


With Steam now being available on Linux, I've installed it there and downloaded WoG. However, compared to how it runs in Windows, it doesn't run that great on Linux. It seems the maximum resolution is 1280x720. I edited the config.txt file with:

<param name="screen_width" value="1920" />
<param name="screen_height" value="1080" />

But it doesn't help. I still get 1280x720 that gets scaled up to 1920x1080, which results in a very large mouse cursor and big, unsharp fonts compared to the Windows version.

Another issue is that there's stuttering in the game when scrolling. In Windows, it's perfectly smooth like butter. In Linux, it has a constant stutter all the time when scrolling around. I tried to disable VSync both in the NVidia settings as well as in the config.txt, and VSync indeed gets disabled (there's tearing), but the stuttering is still there :-/

Is there something I can do about all this?

My system:

Gentoo Linux AMD64
GTX 560 Ti GPU with 313.26 drivers
KDE 4.10.1
xorg-server 1.14.0
Kernel 4.8.4
Core i5 CPU and 16GB RAM

Joined: 03/25/2013

Notify me when new comments are posted.

Joined: 09/01/2009

I'm not sure what would cause these issues; it generally works fine for me after installing the NVIDIA drivers. Do other games work fine in your system? Also, have you tried what's mentioned here? Aside from that, I'm not sure.

Joined: 03/25/2013

Other games work fine and are smooth. (Counter-Strike, CS: Condition Zero, CS: Source, Team Fortress 1 & 2).

The post you mention doesn't apply to me, as I have the Steam version. The libs32 directory only contains "" here. Though it seems it gives me the 32-bit version instead of the 64-bit one.

I have tested it now on a friend's computer, running Ubuntu 12.04 with an AMD card (Radeon 6850.) Same problem there. Funny thing is, he said the game looked just fine to him. I can imagine that people who don't play the Windows version would think the game runs fine. I guess I would think that too. Really, it doesn't. Once you see how perfectly and absolutely smooth the game is under Windows, then it becomes clear that the Linux version is problematic.

Another issue I have is that Alt+Tab doesn't work. If I have to reply to an incoming chat, or email, or do whatever else, I have to quit the game and restart it all the time :-/

Joined: 04/29/2011

As long as I can remember, the Steam doesn't apply 1.30 Patch that fixes many resolution problems. Maybe thats the problem?

Joined: 03/25/2013

Is there a way to see what version I have?

Joined: 04/29/2011

I don't really now. The executable of 1.30 patch can launch levels from command line if you type it like this:

Try that.

Joined: 03/25/2013

Command line parameters in Steam are configured in Steam itself. What parameter should I pass?

Joined: 12/23/2010

I don't think there's a patch for Linux anyway, only for Windows (at least, that's the case on this page). Possibly because they added the patch fixes in the Linux release directly.

Joined: 08/06/2010

I believe the current Linux version is 1.4, with the big improvement being multi-mouse support. Look in your config file for the "manymouse" option, that'll only be there in 1.4.

Another Planet finally has an official release! Download chapters 1 through 3 here! Thank you for waiting so long while I kept starting over.

Joined: 03/25/2013

Yep, it's there:

<param name="manymouse" value="false" />

Joined: 04/29/2011

Well, this means there's no problem with version. I can say that you have better version than me(I have 1.30) Wink
What the matter then? Shock

Joined: 09/17/2012

Do you think its a screen problem rather than than the game? (thats the problem going with me in windows)

My Profile